Häufig gestellte Fragen (FAQ)

Hier möchte ich einige Fragen beantworten, die mir in letzter Zeit häufiger gestellt werden.

 

Wie deinstalliere ich Lexikon-Plug-ins?

Die Lexikon-Plug-ins liegen entweder im Verzeichnis /Library/Dictionaries (für alle Benutzer-Accounts verfügbar) oder in ~/Library/Dictionaries (individuell für jeden Account). Es genügt also, dort das entsprechende Plug-in zu löschen. Die Änderung wirkt erst nach einem Neustart des Lexikon-Programms.

Für ältere Versionen von OS X: Um auch den Papierkorb entleeren zu können ist aber ein Neustart nötig. Alternativ kann auch der Prozesses DictionaryPanel über das Dienstprogramm Aktivitätsanzeige beendet werden.

Wie überprüfe ich, welche Versionen der Plug-ins installiert sind?

Die Versionsnummer steht auf der Seite „Vorderer/hinterer Teil“. Man gelangt zu ihr über das Gehe-zu-Menü. Auf dieser Seite wird auch direkt angezeigt, ob eine neue Version verfügbar ist.


Wird es die Wörterbücher auch für das iPhone geben?

Nicht von mir. Ich besitze leider noch nicht die Fähigkeiten etwas für das iPhone zu programmieren. Es gibt zwar mittlerweile einige Lexikon-Apps, aber leider nutzen die wieder ganz andere Dateiformate.

Warum funktioniert das direkte Nachschlagen nicht in Firefox oder anderen Programmen (alte MS-Office-Version)?

Das systemweite Nachschlagen im Lexikon (⌃⌘D) funktioniert nur in nativen Mac-OS-X-Programmen (Cocoa). Firefox und auch einige andere Anwendungen basieren aber auf anderen Technologien und sehen nur rein optisch wie echte Mac-Anwendungen aus. Für Firefox gibt es aber zumindest das Add-on Look Up in Dictionary oder das Mac OS X Dictionary Add-On, welche das Kontextmenü um einen entsprechenden Befehl ergänzen.

Kann ich die Benachrichtigung auf neue Versionen abschalten oder die Fußzeile ausblenden?

Ja, das ist über die Einstellungen von Lexikon möglich. Seit OS X 10.7 ist die Einstellung aber wegen des Dictionary-Caches nicht sofort wirksam. Damit sie wirksam wird, muss das Plug-in einmal kurz deaktiviert und wieder aktiviert werden.


Ich habe macOS 10.12 Sierra installiert und finde den Dictionaries-Ordner nicht mehr.

Bei einem frisch installierten macOS 10.12 wird der Ordner /Library/Dictionaries nicht mehr automatisch angelegt. Dort residierten einst die von Apple mitgelieferten Wörterbücher, die Sierra nun erst bei Bedarf aus dem Internet nachlädt. Man kann den Ordner weiterhin manuell erzeugen, um dort Lexikon-Plug-ins abzulegen, die für alle Benutzer-Accounts sichtbar sein sollen. Mit der Installation von Sierra wird nun der Ordner ~/Library/Dictionaries für jeden Account automatisch angelegt. Dieser öffnet sich nun auch, wenn man den Menübefehl „Ablage→Lexika-Ordner öffnen“ aufruft.

Wo liegen in macOS 10.12 Sierra die System-Wörterbücher?

Aktiviert man in den Programmeinstellungen eines der von Apple bereitgestellten Wörterbücher, wird es erstmal aus den Internet nachgeladen – zu erkennen am Fortschrittsbalken unten links im Fenster. Länger nicht mehr benutzte Downloads löscht Sierra automatisch wieder, sofern man die Funktion Speicher optimieren aktiviert hat.

Die von Sierra verwalteten Downloads versammeln sich in folgendem Verzeichnis. Manuell löschen lassen sie sich dort aber nicht.

/System/Library/Assets/com_apple_MobileAsset_DictionaryServices_dictionaryOSX

Kann man den Webkit Web Inspector im Lexikon aktivieren?

Ja, das geht mit folgendem Terminal-Befehl. Danach lässt über das Kontextmenü im Lexikon die HTML-Ausgabe analyseren.

defaults write com.apple.Dictionary WebKitDeveloperExtras -bool YES

Wird es weitere Lexikon-Plug-ins (z. B. Deutsch-Französisch) geben?

Es gibt bereits ein paar weitere Plug-ins. Auf der Plug-in-Übersicht habe ich entsprechende Links eingepflegt.

Prinzipiell kann ich natürlich für alle Sprachen ein Plug-in erstellen. Die Grundlagen dafür habe ich mit meinem kleinen Python-Skript geschaffen und es lässt sich (für mich) leicht an neue Gegebenheiten anpassen. Das Problem ist aber, dass ich eine Datei als Basis für ein Plug-in benötige. Ohne Datei kein Plug-in für das Lexikon-Programm. Wer also weitere Wörterbücher kennt, die als Datei (Textdatei oder XML-Datei) herunterzuladen sind, möge mich doch bitte darüber informieren. Wichtig ist, dass die Datei auch generell verwendet werden darf.

Mit dem DictUnifier können zudem Wörterbücher von StarDict in ein Lexikon-Plug-in umgewandelt werden. Für StarDict gibt es viele sehr umfangreiche Wörterbücher, unter anderem auch für Deutsch.

Warum werden die Plug-ins nicht mehr als Installationspaket bereitgestellt?

Früher hatte ich ein Installationspaket bereitgestellt, das automatisch das Lexikon beendet und die Plug-ins aktiviert. Dazu habe ich den PackageMaker verwendet, den Apple nun als veraltet deklariert hat. Das Aktivieren eines Plug-ins funktionierte eh nicht mehr und zudem möchte ich keine 100 Euro ausgeben, nur um den Installer zu signieren. Das wäre nötig, damit er direkt per Doppelklick funktioniert und keine Warnung ausgibt.

Beim Anzeigen der Einträge erscheint nur eine leere Seite.

Das Problem tritt bis OS X Lion auf, wenn man das Wörterbuch im Lexikon-Programm umbenennt und das Kleiner-als-Zeichen (<) verwendet. Das Zeichen darf leider nicht verwendet werden.

Beim Nachschlagen von Wörtern in Safari öffnet sich immer ein neues Lexikon-Fenster.

Seit Snow Leopard öffnet sich bei dem Befehl „Im Lexikon nachschlagen“ z. B. über Safari für jedes nachgeschlagenes Wort ein neues Lexikon-Fenster. Mit folgendem Terminal-Befehl lässt sich das Verhalten von Leopard wiederherstellen, so dass jedes nachgeschlagene Wort im bereits sichtbaren Lexikon-Fenster angezeigt wird.

defaults write com.apple.spotlight DictionaryLookupEnabled -bool NO

Die Plug-ins können nicht installiert werden.

Bei einigen Anwendern sind folgende Probleme aufgetreten (gilt nur für die alte Version mit dem Installationspaket):

Die Installation bricht mit einem Fehler ab (z.B. dass ein Skript nicht ausgeführt werden konnte).

  1. In den meisten Fällen liegt das Problem an fehlerhaften Zugriffsrechten. Das Reparieren der Zugriffsrechte mit dem Festplattendienstprogramm schafft in den meisten Fällen Abhilfe.

Bei der Installation ist kein Volumen sichtbar, auf welchen das Plug-in installiert werden könnte.

  1. Ein Neustart des Systems behebt dieses Problem.

Das Installationsprogramm behauptet, dass es das Plug-in nicht installieren kann, da die Systemvoraussetzungen nicht erfüllt werden. Jedoch habe ich definitiv Leopard installiert.

  1. Wenn weder ein Neustart noch die Reparatur der Zugriffsrechte mittels des Festplattendienstprogramms das Problem beseitigt, hilft leider nur das erneute Aufspielen des Combo-Updates von Apple.

Warum gibt es keine Tiger-Version (10.4) der Lexikon-Plug-ins?

Apple hat mit Leopard einiges am Lexikon verändert und die Erstellung eigener Wörterbücher extrem vereinfacht. Vorher musste man Ahnung von Objective C und Xcode haben und das ist für mich leider noch ein Buch mit sieben Siegeln. Das mit Leopard eingeführte Dictionary Development Kit wird laut meinen Recherchen auch nicht mehr für Tiger nachgereicht. Dank des DDK muss man nämlich nur eine spezielle XML-Datei erstellen.